Skip to main content

Posts

Showing posts from May, 2009

Sound sharing with ubuntu

Ubuntu has a supper cool feature for people who would like to share the sound between multiple machines.
This allows for a computer connected to a HI FI sound system, to share this system with several other machines.

It's also super simple to setup.


Install:
sudo apt-get install paprefs paman padevchooserOn the machine in where you want the sound system to be available to other machines
goto System->Preferences->PulseAudio Preferences and change it to look like the picture



On the system where you want where you want the sounds applications to run
Install:
sudo apt-get install paprefs paman padevchoosergoto System->Preferences->PulseAudio Preferences and change it to look like the picture


Also go to Applications->Sound & Video->Pulse Device Chooser, this will add a icon to your task bar. Check the "Start applet on session login", for future reboots.





Final step is just to select the server where you want the sound to be played.
Just on the click Pulse Audio app…

VirtualBox can't operate in VMX root mode

If you get this message from VirtualBox:

VirtualBox can't operate in VMX root mode. Please disable the KVM kernel extension, recompile your
type:
sudo modprobe -r kvm_intel
Run VirtualBox again that should fix the problem.

Transparent VirtualBox window with compiz manager

If you getting a transparent VirtualBox window, you can start VBox like this to fix the problem:
env XLIB_SKIP_ARGB_VISUALS=1 VirtualBox
references:
https://bugs.launchpad.net/ubuntu/+source/virtualbox-ose/+bug/292588
http://ubuntuforums.org/showthread.php?t=1160178

Ubuntu Jaunty unstable with video ATI chipset

If you have a laptop or machine with a ATI video card and you install Ubuntu Jaunty, you probably notice it's not stable and X freezes very frequently.

This fixed my problem:

# http://temp.minimum.se/mesa_with_fixed_ati_bug/
# 32 bit
wget http://temp.minimum.se/mesa_with_fixed_ati_bug/libgl1-mesa-dri_7.4-0ubuntu3_i386.deb
wget http://temp.minimum.se/mesa_with_fixed_ati_bug/libgl1-mesa-glx_7.4-0ubuntu3_i386.deb
sudo dpkg -i libgl1-mesa-dri_7.4-0ubuntu3_i386.deb libgl1-mesa-glx_7.4-0ubuntu3_i386.deb

# for 64 bit
# replace i386 with amd64

Reference:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/368049